GCompris talk:Community Portal

From GCompris
Jump to: navigation, search

From tselling

drawnumber works now, but clickanddraw seems to just hang when it tries to load. I don't get an error, but just says "Starting..." with the flashing icon on the olpc home screen where you see the activities.

Also, on the home screen where you see running programs, the specific activity name is never there for any of the games I tried. They all say "GCompris", so its impossible to tell which game is which when more than one is running.

From Bruno

I uploaded a new version of clickanddraw and drawnumber. Please have a test. Will check other problem asap.

From tselling

Problems with activities on OLPC

I have recently received an OLPC from the G1G1 campaign. I am trying to set it up for my son and I have found that many of the GCompris activities do not work. Also I have not found any game where there is any sound. I will list the problems I found. Please let me know if there are any fixes. Thanks.

I get "Couldn't find or load the file skins/gartoon/bar_bg.jpg This activity is incomplete. Exit it and report the problem to the authors" for: magic_hat_plus wordsgame readingv erase_clic memory_sound_tux

I get "Couldn't find the board menu, or plugin execution error" for: sudoku drawnumber watercycle anim mosaic

I get "Couldn't find or load the file skins/gartoons/timers/clock10.png This activiy is incomplete. Exit it and report the problem to the authors" for: read_colors

On Exit, do we really need the Are you sure you want to Quit? with Yes/No prompt? I just think thats annoying, especially since its so slow to paint.

From Bruno

This is fixed. You can download the fix at the usual place.

From mgreen

New to XO (OLPC) - Getting an error on using software (followline.activity) "Couldn't find the board menu, or plugin execution error" with "OK" button. Then screen shows red pointer (cursor) and bottom icons (airplane, tools, dice, lips, thumb and home) but no menu.

What am I missing to use the software? I've tried downloading directly to XO, downloading to SD card. I've tried running from SD card and also copying from SD card to Journal and Resume. All approaches have same error message.

Clicking Dice, Lips, Tools icon quits screen. Clicking Airplane shows a brief GCompris beta message then quits. Clicking Thumb has no response. Clicking Home clears icons from lower area but does not quit application, red cursor is still working.

Any suggestions to help me (others) get this software working would be appreciated. In my other computer life I use both Macintosh and Windows computers. -- MG

GCompris on OLPC as application doesn't fill screen

I was having so much trouble with GCompris activities on the OLPC that I decided to install the whole thing on my OLPC with "yum install gcompris". This seems to work except that it does not fill the screen (but music works). Is there a way to make GCompris fill the OLPC screen and just add one activity for "GCompris"? I would actually like that better than a ton of activities I have to install. Thanks.

From Bruno

- Yes, you can enter the GCompris configuration menu, select 1024x768 and restart GCompris.
- It should be easy to create a /usr/share/activities/gcompris on your XO and add in it the mandatory files for Sugar to recognize it and display it's icon. You can look at the other GCompris activities I provide to check how to do that.

(For the other problem you experience, I am facing time constraint and did not work on them.)

From tselling

I tried making GCompris an activity by looking at babyshapes, but not having much luck. I wind up with a constantly flashing GCompris icon and a filled circle instead of jut the GCompris icon in the Home page when I start GCompris. Also 1024x768 doesn't fill the screen either so just not having much luck at all. I am wondering where you got the information to create all those scripts, if I had some documentation on sugarizing I could probably get it working right... but haven't found much.

ALso, I put gcompris.bin /usr/bin like the original gcompris executable and it works somewhat. I get 1200x900 resolution.... but I have to use the -l option. It works for many specific games in the full gcompris install, and for some of the sections. But not sure if there is anyway to get the new executable to work against the main gcompris menu. I get that it can't find or load file... but doesn't say what file. If I give -l /strategy/chess, I can do the 3 chess games. But while -l /strategy brings up a screen if I click on the strategy icon to get to the lower level, gcompris crashes.

From Bruno

OK, as you insist, I am doing a refresh of the port. I fixed my generation script and now more activities should work. As you insist, I am also working on a full bundle. Please join our development mailing list if you want to help, it's easier to communicate. For the bundling how to, it's all documented on the olpc wiki. Now if you go back on the olpc GCompris page, you will see there is a new full activity bundle. Please have a test.

From tselling

Great thanks. I will definitely look into joining the development mailing list.

From Anonymous

Would really like to find more information here on making custom activities here. Where can I learn how to make custom activities for GCompris? Anonymous 11:27, 2 Feb 2008 (CET)

Bruno 14:43, 2 Feb 2008 (CET)

Have you checked the Developer's corner?.

Silent installation of GCompris

Is there anyway I can silent install GCompris?

Bruno 14:43, 20 March 2008 (CET)

On Windows install is once and copy the installation directory on as many computer as you want. There is nothing in the registry.